The shoutbox is currently out of service. Join us on Discord instead.
You can help CodeWalrus stay online by donating here.

Forum reply notifications glitch

Started by DJ Omnimaga, June 14, 2016, 04:22:32 pm

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

DJ Omnimaga

June 14, 2016, 04:22:32 pm Last Edit: June 14, 2016, 04:31:19 pm by DJ Omnimaga
It has come to my attention that several members have started receiving notifications for replies in topics they posted in a week ago. This is most likely due to a bug with SMF 2.0.xx theme config in the admin panel.

A week ago or so, board notifications have been set to be enabled by default for all future member accounts (can be disabled at will), while existing accounts were set to remain untouched by those changes. This was done via the "Configure guest and new user options for this theme" page. However, as it turns out, a SMF bug caused those options to be changed for existing accounts as well on a random basis (for example, my account remained unaffected). I have submitted the issue to SMF's bug tracker on Github.

This is my current setup:


If you would like to disable notifications for new replies, you should try to have your options set this way, under profile->modify profile->notifications. Make sure that the list of topic at the bottom of that page is empty like in my screenshot, else you might still receive notifications for them.


However, for users who aren't very active here, it is generally recommended to enable notifications of replies at least, so that you won't miss out on replies to your posts. For more active users, the Recent Posts page is a better alternative.

Powered by EzPortal