CodeWalrus

CodeWalrus Website => Site Discussion => Site Discussion & Bug Reports => Topic started by: DJ Omnimaga on June 14, 2016, 04:22:32 pm

Title: Forum reply notifications glitch
Post by: DJ Omnimaga on June 14, 2016, 04:22:32 pm
It has come to my attention that several members have started receiving notifications for replies in topics they posted in a week ago. This is most likely due to a bug with SMF 2.0.xx theme config in the admin panel.

A week ago or so, board notifications have been set to be enabled by default for all future member accounts (can be disabled at will), while existing accounts were set to remain untouched by those changes. This was done via the "Configure guest and new user options for this theme" page. However, as it turns out, a SMF bug caused those options to be changed for existing accounts as well on a random basis (for example, my account remained unaffected). I have submitted the issue to SMF's bug tracker on Github (https://github.com/SimpleMachines/SMF2.1/issues/3487).

This is my current setup:
(https://img.ourl.ca/notifications-1.png)

If you would like to disable notifications for new replies, you should try to have your options set this way, under profile->modify profile->notifications. Make sure that the list of topic at the bottom of that page is empty like in my screenshot, else you might still receive notifications for them.


However, for users who aren't very active here, it is generally recommended to enable notifications of replies at least, so that you won't miss out on replies to your posts. For more active users, the Recent Posts (https://codewalr.us/index.php?page=recent2) page is a better alternative.