August 12, 2020, 08:47:34 pm

The shoutbox is currently out of service. Join us on Discord instead.
You can help CodeWalrus stay online by donating here.

WARNING: DO NOT UPGRADE your TI-83 Premium CE or TI-84 Plus CE to OS 5.5.1 and higher. It removes all compatibility with most games and removes ASM/C programming! DOWNGRADING IS IMPOSSIBLE. BE WARNED! Likewise, do NOT update your TI-Nspire CX past OS 4.5.0, else using Ndless and ASM/C programs will be impossible.

Ndless 4.0.3 released !

Started by critor, January 02, 2016, 09:22:35 pm

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.


January 02, 2016, 11:21:04 pm #15 Last Edit: January 02, 2016, 11:38:34 pm by semiprocoder
Also, how do you make it so that pressing escape on the gameboy emulator doesn't restart the calc(thus uninstalling ndless, forcing me to reinstall it every single time)?
My cemetech username is awesommee333.


You can't :/ but you could if there is a way to down grade to 3.1 :P


Quotethat pressing escape on the gameboy emulator doesn't restart the calc

That shouldn't happen. Which game? Does it work on 3.1, 3.6, 3.9?


It does cause it to reboot. I just don't want it to cause I don't feel like reinstalling ndless each time. Its not a big annoyance so I am not complaining, just if there is a way to stop it from rebooting that would be nice.
My cemetech username is awesommee333.

DJ Omnimaga

IIRC, the GB emulator uses ASM. Could it be using OS-specific memory addresses?


Or just use the NES emulator, lawn mover is my fav ^.^

DJ Omnimaga

I fixed two of the links in the first post, per Adriweb request. The tutorial link was broken and the file now links to Github.

Lionel Debroux

QuoteNspire OS 5.0 coming out tomorrow, fixing exploit used by Ndless 4.0.3

Not exactly tomorrow, but probably by the end of February, indeed, if their usual timelines (code fix in a matter of days, then a month or so of testing) hold.
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TIEmu and TILP.
Co-admin of TI-Planet.


January 03, 2016, 02:41:39 pm #23 Last Edit: January 03, 2016, 02:43:58 pm by critor
I've had a look at nClock, and noticed the author hadn't even updated it for Ndless 3.9, the latest version dating from March 2014. :o
So with the help of Vogtinator, we've worked on catching up.

nClock 1.0.7 new features :
  • Full Ndless 4.0.3 support
  • Partial Ndless 3.9 support :
    • TI-Nspire CX CAS 3.9.1
    • TI-Nspire non-CAS 3.9.0

TI-Nspire CX non-CAS 3.9.1 and TI-Nspire CAS 3.9.0 aren't supported for now.

Download :


Nice critor, I use that quite a lot actually ;)


What can I do? Cause my calc is now stuck at the loading thing after loading the os.

What I did was I installed zlock. Then I accidentally typed in a few random letters, and then pressed enter.
I thus deleted and reinstalled zlock, instead of uninstalling and reinstalling, cause well, idk why.
Then I ran ndless, leading me to a lock screen that I couldn't open.
Finally, I pressed the button on the back, rebooting my calc and going into that screen.
My cemetech username is awesommee333.


January 03, 2016, 05:16:56 pm #26 Last Edit: January 03, 2016, 05:47:34 pm by critor
@semiprocoder You have nSonic2MS which, in my opinion, offers you a much better protection than zLock.

Such problem can happen after a crash - it's not specific to Ndless.
You need to run the Diagnostic software :
  • press reset - don't release it
  • press and hold the 3 following keys : [esc] [menu] [minus] - do not release them
  • release the reset button - don't release the 3 keys
  • if the calculator doesn't automatically turn on , press [on]
  • and now you can release everything

The diagnostic software should start immediately and tell you about a GPIO error.
Press [esc] to fix it.
And then, reset. :)


January 03, 2016, 05:19:43 pm #27 Last Edit: January 03, 2016, 05:26:17 pm by semiprocoder
Thanks it works now! Yay! Thank you so much!
My cemetech username is awesommee333.

Max Leiter

Maybe its time to get an Nspire, this looks awesome.

DJ Omnimaga

Keep in mind that TI will most likely block Ndless and downgrades in the next OS release at any moment, though. So make sure to get a calc that runs OS 4.0.3 or lower.

Powered by EzPortal