The shoutbox is currently out of service. Join us on Discord instead.

Macintosh PowerBook 190cs [Fix?]

Started by Unicorn, June 05, 2015, 05:00:23 am

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Unicorn

Well, I just acquired a Macintosh PowerBook 190cs. It seems like the place where the power cord is plugged in is not connected well enough. When wiggling the connection around, the screen occasionally flashes yellow.

Anyways, I was thinking, could this be fixed? I'm going to open it up and take some pictures tomorrow.

So, yeah, It might be cool to have around. :D



??? ??? ??? ??? ???

DJ Omnimaga

I think this could probably be fixed if it's just the cord, if you know how to do it, but I am more curious about what are the specs of that machine. Also @Caleb Hansberry likes old computers :P

Unicorn

I don't think it is the cord, it seems like the jack for the cord is the culprit.



??? ??? ??? ??? ???

Unicorn




??? ??? ??? ??? ???

Ivoah

Well, even if you did fix it, there wouldn't be much you could do with it. It doesn't even have a PowerPC processor, so no linux, and the latest Mac OS it can run is Mac OS 8.1

Unicorn

I don't think that was necessary, as you posted that on cemetech, but, it would be pretty cool to have lying around!

I also pretty much broke the case, so it's not going back together again the way it came. :P



??? ??? ??? ??? ???

DJ Omnimaga

Does the fluid means the PowerBook is now dead for good? Or did it manage to not hit important parts?

Unicorn

Well, I think the screen is probably broken, but I think I could make it work, if It doesn't require a battery.



??? ??? ??? ??? ???

Powered by EzPortal