July 04, 2020, 03:14:51 pm

The shoutbox is currently out of service. Join us on Discord instead.
You can help CodeWalrus stay online by donating here.

WARNING: DO NOT UPGRADE your TI-83 Premium CE or TI-84 Plus CE to OS 5.5.1 and higher. It removes all compatibility with most games and removes ASM/C programming! DOWNGRADING IS IMPOSSIBLE. BE WARNED! Likewise, do NOT update your TI-Nspire CX past OS 4.5.0, else using Ndless and ASM/C programs will be impossible.

[Minecraft] [HP Prime] MinePrime - Minecraft on a Hp Prime!

Started by alexgt, April 20, 2015, 12:22:42 am

Previous topic - Next topic

0 Members and 4 Guests are viewing this topic.

DJ Omnimaga

Tim Wessman once posted an advice which I quoted above, but even that didn't work it seems. ANd there is a Youtube video and I send stuff exactly as demonstrated, but for MinePrime and earlier versions of SIFS it still doesn't work (and even with the current version of SIFS, it took me three tries before I finally get it to work)

Unicorn

Ah! But it did work! So that means there's hope yet! :) I wonder what went right the time it worked...



??? ??? ??? ??? ???

alexgt

Quote from: DJ Omnimaga on July 14, 2015, 02:51:08 am
Tim Wessman once posted an advice which I quoted above, but even that didn't work it seems. ANd there is a Youtube video and I send stuff exactly as demonstrated, but for MinePrime and earlier versions of SIFS it still doesn't work (and even with the current version of SIFS, it took me three tries before I finally get it to work)

Tim Wessman was correct I just got it wrong so it was my fault :(
now it is working but we need to inform everyone that you MUST have this code in your App just in case:
#pragma mode( separator(.,;) integer(h32) )
You can also do that by pressing menu and selecting insert pragma but make sure that it has h32 not something else as that was the problem. Everything works just two characters screwed up the whole App

Quote from: Unicorn on July 14, 2015, 02:49:26 am
Or someone sends an email to hp or they read that forum post you made. I think someone needs to make a youtube video explaining how it works.

I am going to start a series on that/ programming in HP PPL since I know I learn best from vids I hope other people learn well from them to :)

The problem was my fault so do not be alarmed (unless this patch does not work but I garentee it will) Apps work fine but it did take allot of trouble shooting the problem  is solved :)

DJ Omnimaga

Nope, even that version doesn't work. :(

alexgt

July 14, 2015, 02:12:48 pm #304 Last Edit: July 14, 2015, 02:17:04 pm by alexgt
Ok, this is weird, I cleared the memory on my emu and it didn't work (same problem as you). Then I thought it needs to compile the code or something! and so I went to the program menu edited the App (didn't change any code) and exited the editor and the App ran fine. I will make an updated video explaining this :)
Steps:
1. Install latest version of MinePrime (if you already have go to step two)
2. Run MinePrime (if it works and you see the title menu skip the rest of the steps otherwise continue :))
3. Go to the Program Menu (Shift + 1)
4. At the top of the page click on MinePrime (App) to edit it
5. Once you are in the editor press Esc
6. Now run MinePrime from the App menu

I think the problem is that the app says to the program "you are not compiled" and so it will not let it run so by exiting the program editor you compile it and the app says "OK, you are compiled you may run now :)"

This better be the problem <_<

EDIT: this post was my 1000th post O.O

DJ Omnimaga

I hope it works. Hp should have this done on runtime if it's the case and that the code isn't compiled.

I'll trylater tonight.

Unicorn

If it doesn't work, maybe a post on the prime forums will catch HP's attention?



??? ??? ??? ??? ???

DJ Omnimaga

Oh, there is already a topic there. I'll bump it if the new solution doesn't work.

alexgt

Quote from: DJ Omnimaga on July 14, 2015, 03:33:45 pm
I hope it works. Hp should have this done on runtime if it's the case and that the code isn't compiled.

I'll trylater tonight.

Ok, I hope this works but I am very certain this will work since I replicated your problem, but I agree that it should be compiled on runtime :)

Unicorn

Well, in any case, it's not very user friendly :P



??? ??? ??? ??? ???

DJ Omnimaga

Quote from: alexgt on July 14, 2015, 09:01:03 pm
Quote from: DJ Omnimaga on July 14, 2015, 03:33:45 pm
I hope it works. Hp should have this done on runtime if it's the case and that the code isn't compiled.

I'll trylater tonight.

Ok, I hope this works but I am very certain this will work since I replicated your problem, but I agree that it should be compiled on runtime :)
Ok so I tried your solution and neither that worked >.<

alexgt

 >:(  :banghead: :crazy: ???  O.O WTF!!!!!!!!

I have no I dea, try sending it and trouble shooting on the emu and then transferring it from the emu to the irl clac?!

DJ Omnimaga

July 15, 2015, 01:26:52 am #312 Last Edit: July 15, 2015, 01:55:49 am by DJ Omnimaga
Direct transfer from emu to calc are no longer possible on Hardware revision A. That feature was removed about 4 firmwares ago.

EDIT:

Ok so I tried your sending trick and recompile on the emulator and it still won't run. However, I noticed that the following screen appears for about 0.1 seconds before the spreadsheet appears:



I had to use a video capture software in order to extract the frame, else it disappeared too fast.

Also, I forgot to mention that earlier, the first three times I tried to delete then resend your app to my calc, my calc froze.


EDIT: After further tests, I managed to run it on-calc! (somewhat)! O.O However, it won't get past the loading screen. After the loading, it displays the spreadsheet again >.<

On the emulator, it still displays the title screen or parts of it for a split second before quitting to the spreadsheet. The farthest it reached was this screen:



So we have now found part of what is happening: Your game exits prematurely and until now it exited so fast that it was unnoticeable.


And after another ON+Symb, the game now runs on-calc! I can't count how many tries it took me.

From symptoms seen in MViewer GX (crashes when sending many 2 MB files) I am thinking that the calculator RAM gets lower and lower after every APP transfer and your game probably runs out of RAM. In fact, I ran the game again now then moved east for one minute and it eventually exited to the spreadsheet.


HP should make the firmware clear any RAM usage after file transfers and everytime we exit a program back to the home screen or program menu. With mViewer GX, we basically have to press ON+Symb after every file transfer and that's when the actual transfer won't freeze the calc.

Unicorn

Yay! So HP didn't get the ram usage right in the firmware updates?



??? ??? ??? ??? ???

DJ Omnimaga

I think that was an issue since the very beginning.

Powered by EzPortal