September 21, 2020, 03:06:35 pm

The shoutbox is currently out of service. Join us on Discord instead.
You can help CodeWalrus stay online by donating here.

WARNING: If you have a TI-83 Premium CE or TI-84 Plus CE running OS 5.5.x or higher, then you will need ArTIfiCE in order to run ASM/C/ICE programs and some games such as First Fantasy and 1000 Bornes also requires ASMHOOK.

WARNING: Do NOT upgrade your TI-84 Plus CE to OS 5.5 and higher. It blocks ASM!

Started by DJ Omnimaga, May 20, 2020, 04:39:51 pm

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.

critor

New milestone.

OS 5.5.1 which did remove asm programs support was only for the french TI-83 Premium CE, not the international TI-84 Plus CE.

But now there is OS 5.5.5 for the TI-84 Plus CE and of course it removes asm as well, this time on the last TI calculators still supporting it :
https://tiplanet.org/forum/viewtopic.php?t=24097&p=254657#p254657


A new major step just began in asm programs annihilation on the CE...

DJ Omnimaga

I'm definitively not upgrading. I hope that in the future, TI won't make TI-Connect automatically update any calc connected to the computer, either via software or background Windows processes.

critor

84+CE OS 5.6 has just been released with some new things, and of course no asm anymore :
https://tiplanet.org/forum/viewtopic.php?f=41&t=24146

Think very carefully before updating... there is no going back, once updated asm will be removed forever.


DJ Omnimaga

I'm definitively gonna be careful when connecting my calculator to TI-Connect in the future, in case one day TI releases a TI-Connect update that automatically sends the newest OS to any connected TI-84 Plus CE without any warning (I don't know if that would be illegal).

DJ Omnimaga


Yuki

Hey, wait a minute, I'm pretty sure I've seen a story unfolding exactly like this before... Some big company removing a major feature for no other reason than "security"...

Yeah...

Any of you guys daring enough for a class action lawsuit?
Read Zarmina!
YUKI-CHAAAANNNN
In the beginning there was walrii. In the end there will be walrii. All hail our supreme leader :walrii: --Snektron



if you wanna throw money at me and/or CodeWalrus monthly it's here

YvanTT

Hello everyone,

I've just released arTIfiCE, a "jailbreak" for the TI CE calculators with OS 5.5 and 5.6.
It brings back ASM programs and games!



More information, download, install instructions, and an FAQ, are available on the website: https://yvantt.github.io/arTIfiCE/

Yours truly, fighting for the freedom of peaceful assembly,
Enjoy :)

Yuki

Read Zarmina!
YUKI-CHAAAANNNN
In the beginning there was walrii. In the end there will be walrii. All hail our supreme leader :walrii: --Snektron



if you wanna throw money at me and/or CodeWalrus monthly it's here

DJ Omnimaga

Too late everyone, TI has just released a new OS update just a minute ago that patches this... just kidding :P, this is amazing. I'm gonna have a read about this when I get some time. :)

Now if only there was a way to make the Asm() command functional again, so that TI-BASIC games that uses ASM libraries can work again.

DJ Omnimaga

A tool that lets you downgrade to an older OS if your TI-84 Plus/83 Premium CE is hardware revision L or lower (which excludes all Edition Python calculator models) has now been released, although it's still under development. It's called Cauldron: https://github.com/TheMachine02/Cauldron

The original link was https://github.com/Ne3s2-3p4/Cauldron but it's down now.

https://tiplanet.org/forum/viewtopic.php?t=23858&p=255666#p255666


WARNING: Keep in mind that any wrongful manipulation of your calculator boot code or usage of Boot code manipulation without first reading instructions could permanently brick your calculator and that there are still risks otherwise. So be careful!

Powered by EzPortal