August 05, 2020, 07:59:29 pm

The shoutbox is currently out of service. Join us on Discord instead.
You can help CodeWalrus stay online by donating here.

WARNING: DO NOT UPGRADE your TI-83 Premium CE or TI-84 Plus CE to OS 5.5.1 and higher. It removes all compatibility with most games and removes ASM/C programming! DOWNGRADING IS IMPOSSIBLE. BE WARNED! Likewise, do NOT update your TI-Nspire CX past OS 4.5.0, else using Ndless and ASM/C programs will be impossible.

Sqrxz levels won't show...

Started by Switchblade, March 14, 2017, 12:37:25 am

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I have downloaded several Sqrxz levels from ticalc for my TI-86.  However, except for the 3 levels that come with Sqrxz, none show up in the level selection screen.  Does anyone have any hints? Thanks.


Are you sure the version you downloaded was for the right calculator?
Please spam here:

"walruses are better than tuxedo chickens, all hail the great :walrii:" ~ me
Evolution of my avatar:

DJ Omnimaga

March 14, 2017, 01:23:49 am #3 Last Edit: March 14, 2017, 01:25:26 am by DJ Omnimaga
Hm good question, I only got into SQRXZ recently so I doubt I would be able to help much (I really need to dig up my silverlink from the closet to see if TI-Connect can detect a 86 with it), but I think @JamesV or @Travis might own that calculator and might be able to help (especially JamesV since he made the CE version). I wonder if you should backup your calculator content then reset its RAM? On 83+ calcs this often fixes issues.

Which external levels have you tried and which copy of SQRXZ on ticalc have you used? It's possible that there are multiple versions available for the same calculator such as 1.0, 1.1, etc, and that some might have compatibility issues.


March 16, 2017, 11:18:43 pm #4 Last Edit: March 16, 2017, 11:21:18 pm by Travis
I seem to remember that TI Connect on Windows ditched support for "legacy" calcs like the 86 even back when it first came out, though I could be remembering that wrong. But yeah, if you (@Switchblade) could answer DJ Omnimaga's questions, and also tell us which linking software and cable you're using, that might provide a clue. Also, you might try using TILP to transfer the files to the calculator if you haven't already; I seem to recall that there were a few strangely-formatted 86 files out there that can confuse some link programs into transferring bad data. As I recall, TILP can properly handle several of the nonstandard variations.

DJ Omnimaga

The TI page says that TI-Connect supports the TI-86:

I'm unsure which cables are supported, though. Also I indeed remember that certain programs had issues being sent, such as Joltima, regardless of the calc, due to weird compiling formats being used.


Sorry for the late answer, I've been n vacation.  I am using a it silver link with TILP.  Every thing I send to either my 83 plus or 86 sends.  The only problem is, that on the level selection screen in SQRXZ, the levels won't show up, other than the default levels.  The strings are there however, as can be told by looking through the the contents of the memory.  Unfortunately, my 86 had a really bad crash recently.  My younger brother didn't know what he was doing, and started a game of Chessmaster 86 with computer playing against the computer.  The game reach a point where the two moves where simply being repeated, and it was impossible to exit.  I pulled out the batteries, and days later, it still won't turn on.   :banghead:

DJ Omnimaga

Was the crash before trying to install SQRXZ or after your first post?


March 17, 2017, 04:46:54 pm #8 Last Edit: March 17, 2017, 04:54:51 pm by Travis
I feel your pain; 86 crashes can be a pain to recover from sometimes. ;)

The worst crash I had, I had to remove all the AAA batteries and the backup battery, and I think I even put a piece of tape on the ON key to hold it down for a few hours with the batteries removed (somehow that seems to help). It should eventually reset and work again if you do that, even if it takes a while and a number of attempts.

Usually it doesn't take that long, though; often removing the AAAs and holding ON for a minute or so will be enough to drain the remaining charge and allow the processor to hard-reset when you reinstall the AAAs.

Hope that helps!

DJ Omnimaga

I didn't know 86 crashes were that nasty. On the 83, usually you only need to pull a battery and get a mem clear.

Also what is your TI-86 ROM version? Maybe SQRXZ levels aren't compatible with certain newer ROMs


Hey @Switchblade, sorry for not seeing this sooner! :( Did you end up having any luck with this? I do own a TI-86, and I'm sure somewhere I should still have my old cable for it. Are you able to link me to the specific game download you used, and one of the worlds you tried, and I can give it a go to see if I have any success?

Powered by EzPortal