+-Discord Shoutbox

Alternatively, join us on Discord directly.
You can help CodeWalrus stay online by donating here.

Arm64 operating systems for the Raspberry Pi 3

Started by gameblabla, December 29, 2016, 12:21:29 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Quote from: xMarminq_ on January 13, 2017, 03:47:02 AM
Do you think it is possible to attach a Pi to a calc and modify it so it could have wifi on it and have 2 player games? :P
this should be at least technically possible:
make a pi simulate being a calc (it simulates being your opponent, connected to your calc via cable) (--->for two calcs)
make the PIs communicate with each other wirelessly or over the internet to get the actual data from the other pi.

so you have this constellation:
CalcA <-> PiA <- - - - - - - - - - -> PiB <-> CalcB
PiA gets the info from CalcA (via cable) and sends it to PiB (wirelessly or ethernet or whatever).
PiB accordingly gives them to CalcB (via cable), pretending to be the actual CalcA.

problem is: you need two PIs connected to the calcs (extra hardware) for both calcs, so why the f*** dont you just connect the calcs using a cable?
suere that would make it possible to play over ethernet (worldwide multiplayer) but it'S not worth the effort I think.
But maybe you can find someone doing that for you ;)
There should be some guys with the necessary skills around ^^
  • Calculators owned: ti-83+, ti-84+, ti-84+, ti-84+se, ti-84+se(te), ti-nsphire, ti-nsphire CAS, ti-nsphire CX-CAS, ti-voyage, ti-voyage, Who reads this list anyways...?
Anyway war sucks. Just bring us your food instead of missiles  :P ~ DJ Omnimaga (11.10.2016 20:21:48)
if you cant get a jframe set up, draw stuff to it, and receive input, i can only imagine how horrible your game code is _._   ~ c4ooo (14.11.2016 22:44:07)
If they pull a Harambe on me tell my family I love them ~ u/Pwntear37d (AssangeWatch /r/)
make Walrii great again ~ DJ Omnimaga (28.11.2016 23:01:31)
God invented the pc, satan the smartphone I guess ~ p4nix (16.02.2017 22:51:49)


Quote from: gameblabla on January 13, 2017, 03:39:46 AM
So i tried OpenSUSE again and same issue unfortunely :
after the grub menu, some text and then... black screen with a huge pink line on the very left of my display.
I had blacklisted vc4 in /etc/modprobe.d/50-blacklist.conf but it doesn't seem to do anything...

I redownloaded Arch Linux and surprisingly, the compiler worked properly again.
So i attempted to install OpenRC and i rebooted my Pi.
But it would not boot into OpenRC and it's stuck at the kernel level. (no errors, strange)

According to this blog, i must add a kernel parameter pointing to OpenRC.
But where would i add it on my rpi ? It does not use sysconfig...

The journey continues...

I believe it's in /boot/cmdline.txt.
  • Calculators owned: TI-83+ (dead?), Casio Prizm (also dead???)
  • Consoles, mobile devices and vintage computers owned: A lot
Read Zarmina!
In the beginning there was walrii. In the end there will be walrii. All hail our supreme leader :walrii: --Snektron

if you wanna throw money at me and/or CodeWalrus monthly it's here

Powered by EzPortal