CodeWalrus

CodeWalrus Website => Site Discussion => Site Discussion & Bug Reports => Topic started by: TIfanx1999 on December 21, 2015, 06:52:06 pm

Title: Site hangs on login
Post by: TIfanx1999 on December 21, 2015, 06:52:06 pm
Codewalrus and Omnimaga won't load on my win 7 laptop running the most current version of chrome. They hang on the login and just show the orange Loading... text

*Edit* It's working now. On Omnimaga, I changed stay logged in forever to stay logged in for a day and it worked. Not sure what changed here.
Title: Re: Site hangs on login
Post by: alexgt on December 21, 2015, 06:59:16 pm
Hope it keeps working for you, it would suck if you couldn't log on for a ling time xD
Title: Re: Site hangs on login
Post by: Streetwalrus on December 21, 2015, 07:21:32 pm
It's because of Sorunome's mod, that encrypts the password with RSA to provide an extra layer of security when logging in for sites without https. Try logging in with javascript disabled, and poke him about it to debug it.
Title: Re: Site hangs on login
Post by: TIfanx1999 on December 21, 2015, 07:43:49 pm
My internet started acting up afterwards, and I haven't been able to reproduce it. It seems likely that it was on my end afterall.
Title: Re: Site hangs on login
Post by: Streetwalrus on December 21, 2015, 07:48:19 pm
Alright, good to know it works now.
Title: Re: Site hangs on login
Post by: DJ Omnimaga on December 22, 2015, 08:55:39 am
I had the same problem on Omnimaga regardless of which login lenght I selected. I never had issues on CW but I didn't have time to check if it now works on Omni with the new login security mod update.
Title: Re: Site hangs on login
Post by: cheesehead544 on January 09, 2016, 10:21:04 am
If i login from the bar on the left, i get the everlasting loading bar.
but if i login from the top bar, it works.
Title: Re: Site hangs on login
Post by: DJ Omnimaga on January 09, 2016, 11:52:25 am
Interesting. Also one thing to note is that on Omnimaga, I didn't have this happen the second last time I logged in a few days ago, but yesterday it did again. It seems to only happen from the portal, not the forum index, though. I didn't try on CW since I'm always logged in, though.

What I suspect is that when the site is slow-ish, the connection time outs during login, because when I tried logging in on Omni when it didn't work, the site was slow-ish. Maybe Soru needs to check that out.
Title: Re: Site hangs on login
Post by: DJ Omnimaga on January 14, 2016, 03:33:11 pm
/me pokes @Sorunome


Quotecaleb1997   Hello!   10:25:51 AM
caleb1997   I've been having login issues.   10:26:05 AM
caleb1997   I keep trying to log in, and it goes through.... Like, the 10th or 12th try.   10:26:30 AM
caleb1997   It takes me about 9 or 10 minutes to just log in.   10:26:48 AM
caleb1997   Could this be fixed?   10:26:57 AM
DJ Omnimaga   caleb1997 blame Sorunome's mod Tongue   10:28:21 AM
DJ Omnimaga   I think we should maybe get rid of it until he fixes this   10:28:31 AM
*   DJ Omnimaga pokes Streetwalrus   10:28:47 AM
caleb1997   ok.   10:29:14 AM
DJ Omnimaga   Here's the topic https://codewalr.us/index.php?topic=947.0


@Streetwalrus @Juju do you think we could remove Soru's mod until he either fixes this or make it not require javascript? I suspect that JS might be the problem in some browsers, but I could be wrong. But it makes it very hard for people to login successfully.
Title: Re: Site hangs on login
Post by: Sorunome on January 14, 2016, 06:04:03 pm
Quote from: DJ Omnimaga on January 14, 2016, 03:33:11 pm
/me pokes @Sorunome


Quotecaleb1997   Hello!   10:25:51 AM
caleb1997   I've been having login issues.   10:26:05 AM
caleb1997   I keep trying to log in, and it goes through.... Like, the 10th or 12th try.   10:26:30 AM
caleb1997   It takes me about 9 or 10 minutes to just log in.   10:26:48 AM
caleb1997   Could this be fixed?   10:26:57 AM
DJ Omnimaga   caleb1997 blame Sorunome's mod Tongue   10:28:21 AM
DJ Omnimaga   I think we should maybe get rid of it until he fixes this   10:28:31 AM
*   DJ Omnimaga pokes Streetwalrus   10:28:47 AM
caleb1997   ok.   10:29:14 AM
DJ Omnimaga   Here's the topic https://codewalr.us/index.php?topic=947.0


@Streetwalrus @Juju do you think we could remove Soru's mod until he either fixes this or make it not require javascript? I suspect that JS might be the problem in some browsers, but I could be wrong. But it makes it very hard for people to login successfully.

First of all, you cannot revert this mod without making it impossible for certain people to log in (as in, everybody that logged in since the installation of the mod), as I already mentioned a few times.
Second, as already mentioned, the javascript part is optional.

I am willing to look into login issues further if i can recieve said information of somebody effected.
Title: Re: Site hangs on login
Post by: DJ Omnimaga on January 14, 2016, 06:08:08 pm
Ah, that sucks then. As for the JS we think this might be what causes the issues and is why Streetwalrus wanted to know how to disable it earlier (he doesn't know how). As for people affected, @caleb1997 was the last one affected. Would he need to send you the same info as rwill?
Title: Re: Site hangs on login
Post by: Sorunome on January 14, 2016, 06:11:01 pm
I mentioned in some thread somewhere which $modSetting thingy it was, i couldn't find it in the admin pannel but you could delete that entry off the {board_prefix}settings table.
Title: Re: Site hangs on login
Post by: Streetwalrus on January 14, 2016, 06:15:47 pm
And I already said that it's not actually possible to change that value. You should have relied on something else for that.
Title: Re: Site hangs on login
Post by: DJ Omnimaga on January 14, 2016, 07:06:24 pm
Quote from: Streetwalrus on January 14, 2016, 06:15:47 pm
And I already said that it's not actually possible to change that value. You should have relied on something else for that.
I am getting confused here, since I'm completely illiterate about that stuff. Does this mean you cannot disable the javascript thing, or is that the other thing Soru talks about?
Title: Re: Site hangs on login
Post by: Streetwalrus on January 14, 2016, 07:09:17 pm
We're talking about the same thing which is the js thing. There is no way to disable it because the "option" checks a variable which is always true (I grepped the entire smf install).
Title: Re: Site hangs on login
Post by: DJ Omnimaga on January 14, 2016, 07:13:53 pm
Then that's something @Sorunome should probably fix >.<
Title: Re: Site hangs on login
Post by: rwill on January 15, 2016, 08:53:51 am
I just tried to log in and my password was not accepted so I had to reset it... ?
Title: Re: Site hangs on login
Post by: DJ Omnimaga on January 15, 2016, 12:27:03 pm
Could you PM the browser network logs to @Sorunome ? I am definitively starting to think we kinda did a mistake to upgrade to this mod immediately, no offense to Sorunome (bugs happens sometimes). >.< Or it isn't compatible with our current server config.

In any case, never ever use copy/paste to reset your password or to enter your password. Browsers or login forms are purposely designed to change what you paste in the password field to prevent people from using copy/paste, so it will just paste gibberish in the password field. This could be the issue you are having.